Investigating Possible Issue with the Navigation Menu
Incident Report for Xero
Resolved
This incident has been resolved.
Posted Feb 25, 2021 - 02:32 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 25, 2021 - 01:59 UTC
Update
Just to let you know that we’re still working on this - we’ll update you as soon as we have more information.
Posted Feb 25, 2021 - 01:32 UTC
Investigating
Some users may be experiencing intermittent issues with the navigation menu in Xero, we are investigating and will post an update as soon as we have more information.
Posted Feb 25, 2021 - 00:36 UTC
This incident affected: Xero.