UK: Xero Tax - Customers unable to create or reload filings
Incident Report for Xero
Resolved
The Companies House has now resolved the issues causing Xero Tax users to experience error messages when attempting to create or reload filings. We apologise for any inconvenience this has caused.
Posted Apr 08, 2024 - 16:05 UTC
Monitoring
The Companies House has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 3:34 pm UTC
Posted Apr 08, 2024 - 15:35 UTC
Investigating
We are aware that customers are currently experiencing error messages in Xero Tax (UK) when attempting to create or reload filings. Our team is investigating this with urgency.

Status Last Reviewed: 3:08 pm UTC
Posted Apr 08, 2024 - 15:08 UTC
This incident affected: Xero Partner Products & Tools (Xero Tax (UK)).