Our team has resolved the issue impacting customers trying to access bank accounts on the Xero Dashboard. This was caused by a product release, which has been rolled back to resolve customer impact. We apologise for any inconvenience caused.
Posted Feb 18, 2025 - 01:51 UTC
Identified
We have identified what is preventing customers trying to access bank accounts on the Xero Dashboard.
This is our top priority and we will update you as soon as we can.
Status Last Reviewed: 1:44am UTC
Posted Feb 18, 2025 - 01:45 UTC
This incident affected: Xero Platform and Settings.