Employees are not able to be invited into My Payroll
Incident Report for Xero
Resolved
Our Product Team have resolved the issue related to employees not able to be invited into My Payroll.

Please let us know if you still have any issues accessing Xero, and we’ll investigate further.
Posted May 24, 2022 - 01:27 UTC
Investigating
We’re currently aware of an issue were employees are not able to be invited into My Payroll. Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted May 23, 2022 - 23:08 UTC
This incident affected: Xero.