Users are unable to access Xero Central
Incident Report for Xero
Resolved
The issue that was preventing users from accessing Xero Central has been resolved.
Posted 3 months ago. May 18, 2019 - 06:56 NZST
Investigating
We’re currently aware of an issue preventing users from accessing Xero Central. Our Product Team is working to resolve this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted 3 months ago. May 18, 2019 - 06:29 NZST