Philippines - Some customers may be experiencing errors in Xero due to an internet service connection issue

Incident Report for Xero

Resolved

This incident has been resolved.
Posted Sep 24, 2025 - 07:24 UTC

Update

We are continuing to work on a fix for this issue.
Posted Sep 24, 2025 - 07:23 UTC

Update

We've contacted the internet service provider for more information.

Customers can access Xero via mobile data or another internet service provider as normal.

Status Last Reviewed:
Posted Sep 24, 2025 - 07:22 UTC

Update

We’ve identified some Xero customers in the Philippines may be experiencing errors in Xero due to an internet service connection issue.

We are investigating with the internet service provider and will update customers as soon as possible.

Status Last Reviewed:
Posted Sep 24, 2025 - 05:00 UTC

Identified

We’ve identified some Xero customers in the Philippines may be experiencing errors in Xero due to an internet service connection issue.

We are investigating with the internet service provider and will update customers as soon as possible.

Status Last Reviewed:
Posted Sep 24, 2025 - 00:38 UTC

Update

Our product team is looking into this, and we’ll provide an update as soon as possible
Posted Sep 23, 2025 - 23:46 UTC

Update

We are continuing to investigate this issue.
Posted Sep 23, 2025 - 23:24 UTC

Update

We are continuing to investigate this issue.
Posted Sep 23, 2025 - 23:11 UTC

Investigating

We are aware some Asia customers are experiencing errors trying to login to Xero. Our team is investigating this with urgency.

Status Last Reviewed: 11.10 pm UTC
Posted Sep 23, 2025 - 23:11 UTC
This incident affected: Xero Platform and Settings.