Xero Tax - Delays lodging information to the ATO.
Incident Report for Xero
Resolved
We have fixed the issue relating the the lodgment of Individual tax returns. Submitted returns are being processed and should be completed in the next 2 hours.
Posted Nov 14, 2017 - 05:15 UTC
Investigating
We are aware of an issue that may cause a delay in the lodgement of Tax Returns in Xero Tax.

Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted Nov 14, 2017 - 04:44 UTC