Some users may be experiencing errors or slowness when accessing Practice Manager
Incident Report for Xero
Resolved
Our Product Team have resolved the issue that was causing errors and slowness when accessing Practice Manager.

Please let us know if you still have any issues with this, and we’ll investigate further.
Posted Nov 05, 2021 - 16:58 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 05, 2021 - 16:34 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 05, 2021 - 16:24 UTC
Investigating
We’re currently aware of an issue where users may be experiencing errors or slowness when accessing Practice Manager. Our Product Team is investigating this with urgency.
Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted Nov 05, 2021 - 16:00 UTC
This incident affected: Partner Tools & WorkflowMax (Practice Manager).