Investigating Possible Issue with Xero Touch mobile application
Incident Report for Xero
Resolved
Our Product Team have resolved the issue that was preventing users from accessing Xero via Mobile applications.

Please let us know if you still have any issues with this, and we’ll investigate further.
Posted Apr 13, 2021 - 00:05 UTC
Update
We are continuing to investigate this issue.
Posted Apr 12, 2021 - 23:47 UTC
Investigating
Some users may be experiencing errors in Xero while using Xero Touch, Expenses and Xero Me application, we are investigating and will post an update as soon as we have more information.
Posted Apr 12, 2021 - 23:11 UTC
This incident affected: Xero Platform and Settings.