Delay with processing payroll emails
Incident Report for Xero
Resolved
We've now cleared the backlog that caused delays when sending emails from AU, UK and US Payroll.
Posted Jul 14, 2017 - 10:58 UTC
Update
Over the past 2 days we have seen delays of a few hours sending payroll emails out of Xero. The afternoons and evenings (Australian time) are when we're seeing these delays occur the most at the moment.

If any of your employees haven't received their payroll emails by the next morning, please let us know and we'll look into these for you.
Posted Jul 13, 2017 - 06:54 UTC
Update
We've cleared the backlog of payroll emails from yesterday. Due to higher than usual email volumes, there may still be delays of a few hours at some stages when sending payroll emails over the next few days.

Thanks for your patience - we'll let you know when everything returns to normal.
Posted Jul 11, 2017 - 00:11 UTC
Identified
We're aware of a delay with processing Payroll emails right now, and we're working on clearing this. We expect these emails to be cleared within the next 24 hours, but will update you if we have any further news. This affects US, UK and AU Payroll.

If your employees haven't yet received their Payslips and or Payment Summaries (AU only) from Xero, we recommend that you don't send them again as they'll receive multiple emails once we've worked through the backlog.

Apologies for any inconvenience this email delay has caused you.
Posted Jul 10, 2017 - 08:58 UTC