Our team has resolved the issue impacting global customers trying to run Reports in Xero. We apologise for any inconvenience this has caused.
A product release caused Reporting to become unavailable and was rolled back to restore service.
Posted Jul 03, 2025 - 00:02 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.
Status Last Reviewed: 11:45pm UTC
Posted Jul 02, 2025 - 23:45 UTC
Investigating
We are aware some customers trying to run reports in Xero are experiencing an error page, or being directed back to the Reports screen. Our team is investigating this with urgency.
Status Last Reviewed: 11:36pm UTC
Posted Jul 02, 2025 - 23:37 UTC
This incident affected: Core Xero Products (Reporting).