Batch Deposits is currently unavailable
Incident Report for Xero
Resolved
Our team has resolved the issue impacting customers trying to access Batch Deposits. We apologise for any inconvenience this has caused.

We became aware that customers were unable to access Batch Deposits for a short period of time. This was caused by a product release that meant this feature was unavailable. The release has been rolled back and the issue has been resolved. Services are now back to normal.
Posted Jul 26, 2022 - 17:08 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 4.55pm UTC
Posted Jul 26, 2022 - 16:55 UTC
Investigating
We are aware customers are currently unable to access Batch Deposits. Our team is investigating this with urgency.

Status Last Reviewed: 4.51pm UTC
Posted Jul 26, 2022 - 16:52 UTC
This incident affected: Xero Platform and Settings.