Global: Payroll - some customers may be experiencing errors when accessing Payroll

Incident Report for Xero

Resolved

Our team has resolved the issue impacting our customers experiencing errors in Xero. We apologise for any inconvenience this has caused.
Posted Jul 10, 2026 - 20:19 UTC

Monitoring

Our team has implemented a fix and we are currently monitoring the results.
Posted Jul 10, 2026 - 19:57 UTC

Investigating

We are aware that some customers trying to access Payroll in Xero are experiencing an error. Our team is investigating this with urgency.
Posted Jul 10, 2026 - 18:16 UTC
This incident affected: Australia - Regional Products (AU Payroll), New Zealand - Regional Products (NZ Payroll), United Kingdom - Regional Products (UK Payroll), and Xero Mobile Apps (Xero Me).