Some users may experience problems accessing and using Xero.
Incident Report for Xero
Resolved
This incident has been resolved.
Posted 3 months ago. Mar 13, 2018 - 00:22 NZDT
Monitoring
A good news update - we’ve made the changes needed to address the performance issue that has impacted many customers today. We’ll continue to monitor very closely but do not hesitate to let us know if you’re experiencing any further performance issues. We realise this has been disruptive to many of our customers. Once we are confident we have fully resolved the issue we will provide a situation report on our blog.
Posted 3 months ago. Mar 12, 2018 - 22:43 NZDT
Update
We’re continuing to work on resolving the issue. There is no significant update on progress to give, and unfortunately users are likely to still be experiencing some level of performance impact. Thanks for your patience.
Posted 3 months ago. Mar 12, 2018 - 19:56 NZDT
Update
In the past 24 hours, Xero undertook an upgrade to a key database server to improve performance.

This upgrade resulted in an unforeseen performance degradation of the database. The Xero team is working on this as a matter of priority and we will continue to update as we're closer to resolving this.
Posted 3 months ago. Mar 12, 2018 - 17:16 NZDT
Update
We're continuing to experience performance degradation issues and our team is working on resolving this as matter of priority.
Posted 3 months ago. Mar 12, 2018 - 16:25 NZDT
Update
Xero continues to experience performance degradation. Our team has identified an issue and are doing everything they can to ensure Xero is back to full performance soon. We will continue to keep you updated.
Posted 3 months ago. Mar 12, 2018 - 15:26 NZDT
Update
We’re sorry this is causing you some downtime. We very rarely have extended periods of performance degradation like this. Thank you for your support while we fix this for you.
Posted 3 months ago. Mar 12, 2018 - 14:17 NZDT
Update
We're currently working to get affected users back up and running. Thanks for your continued patience.
Posted 3 months ago. Mar 12, 2018 - 13:40 NZDT
Update
We are aware that some users are still experiencing performance issues or unable to login to Xero at all. Our Product Team are still working to resolve this and we’ll update you as soon as we have more information.
Posted 3 months ago. Mar 12, 2018 - 13:12 NZDT
Update
This issue is being worked on as a matter of priority. Our apologies for the inconvenience caused. Please continue to check this page for updates.
Posted 3 months ago. Mar 12, 2018 - 12:48 NZDT
Identified
Our Product Team have identified the cause, and are working to restore your access to Xero as soon as possible. At the moment we're aware that some users aren't able to log into Xero, along with other users experiencing issues once they do log in.
Posted 3 months ago. Mar 12, 2018 - 12:30 NZDT
Update
Our Product Team are doing everything they can to resolve the problems you're having using Xero right now. Thanks for your patience.
Posted 3 months ago. Mar 12, 2018 - 12:16 NZDT
Update
Just to let you know that we’re still working on this - we’ll update you as soon as we have more information.
Posted 3 months ago. Mar 12, 2018 - 12:00 NZDT
Investigating
We're currently aware of some users experiencing slowness working in Xero. Our Product Team are looking into this with urgency, and we'll be in touch as soon as we have an update.
Posted 3 months ago. Mar 12, 2018 - 11:45 NZDT