Global: Xero HQ - Some customers are experiencing errors or slowness when navigating Xero HQ

Incident Report for Xero

Resolved

Our team has resolved the issue impacting some partners when navigating Xero HQ. We apologise for any inconvenience this has caused.
Posted Jul 22, 2026 - 03:28 UTC

Monitoring

Our team has implemented a fix and we are currently monitoring the results.
Posted Jul 22, 2026 - 03:14 UTC

Investigating

We are aware of some customers experiencing slowness or receiving errors when navigating Xero HQ. Our team is investigating this with urgency.
Posted Jul 22, 2026 - 03:02 UTC
This incident affected: Xero Partner Products & Tools (Xero Practice Manager (XPM), Xero HQ).