Global: V2 Reports - Some customers unable to load reports
Incident Report for Xero
Resolved
Our team has resolved the issue impacting customers trying to load V2 reports in Xero. We apologise for any inconvenience this has caused.

Our technical team identified this was caused by poor network connectivity and has restored service.
Posted Apr 10, 2024 - 00:23 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 12:04 AM UTC
Posted Apr 10, 2024 - 00:06 UTC
Investigating
We are aware that some customers may be unable to load V2 reports in Xero. Our team is investigating this with urgency.

Status Last Reviewed: 11:06 pm UTC
Posted Apr 09, 2024 - 23:07 UTC
This incident affected: Core Xero Products (Reporting).