Xero HQ - changes to client access are delayed
Incident Report for Xero
Resolved
Our team has resolved the issue that was causing delays to client access changes in XeroHQ. This issue was caused due to a higher than normal amount of requests to our system which resulted in the delay to client access changes.
We apologise for any inconvenience this has caused.
Posted Feb 15, 2024 - 03:34 UTC
Update
We are continuing to work on a fix for this issue.
Posted Feb 15, 2024 - 03:32 UTC
Identified
We’re currently aware that Practices that have made client access changes in Xero HQ are experiencing a delay in these changes being made.

Our team has identified the cause of this issue and are in the process of implementing a fix.

We apologise for the inconvenience.

Status Last Reviewed: 2.02am UTC
Posted Feb 14, 2024 - 21:08 UTC
This incident affected: Xero Partner Products & Tools (Xero HQ).