Some customers not receiving Xero emails
Incident Report for Xero
Resolved
Our team has identified that this was an issue with one of our third party ISPs who had an outage which meant some customers weren't receiving emails from Xero. This issue has been resolved and customers should now be receiving emails. We apologise for any inconvenience this has caused.
Posted Dec 02, 2022 - 21:51 UTC
Investigating
We are aware some customers aren't receiving emails from Xero. Our team is investigating this with urgency.

Status Last Reviewed: 7.06pm UTC
Posted Dec 02, 2022 - 19:06 UTC