Xero - Some AU customers unable to login to Xero
Incident Report for Xero
Resolved
Our testing shows that this issue has now resolved.. We apologise for any inconvenience this has caused and for customers patience while this was investigated.
Posted Jan 28, 2025 - 00:21 UTC
Investigating
We are aware some Australian customers are experiencing errors logging in to Xero due to a connectivity issue with some internet service providers.

We are investigating this with urgency and thank customers for their patience during this time.

Status Last Reviewed: 11.00pm Monday 27 January UTC
Posted Jan 26, 2025 - 00:22 UTC
This incident affected: Xero Platform and Settings.