Global: Xero - Some customers may be experiencing slowness and errors across Xero

Incident Report for Xero

Resolved

Our team has resolved the issue impacting customers trying to navigate Xero. We apologise for any inconvenience this has caused.
Posted Apr 24, 2026 - 23:35 UTC

Investigating

We are aware some customers trying to navigate Xero are experiencing intermittent slowness and errors. Our team is investigating this with urgency.
Posted Apr 24, 2026 - 23:00 UTC
This incident affected: Xero Platform and Settings.