Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 04, 2025 - 08:00 UTC
Scheduled
The Inland Revenue Department (IRD) is completing planned maintenance from 9:00pm Saturday 4 October 2025 to 3:00pm Sunday 5 October 2025, NZST.
During this time, customers will be unable to file GST returns, income tax returns or payday filings to IRD from Xero. You can complete filings to IRD as normal from 3:00pm Sunday 5 October 2025, NZST.
Please note, you can continue to run and view GST, income tax returns and payruns during this time.
Posted Sep 29, 2025 - 21:05 UTC
This scheduled maintenance affects: New Zealand - Regional Products (Tax Reporting - NZ GST, NZ Payroll) and Xero Partner Products & Tools (Xero Tax (NZ)).