Global: Xero - some customers may be experiencing slowness across Xero
Incident Report for Xero
Resolved
Our team has resolved the issue impacting some customers trying to navigate Xero. We apologise for any inconvenience this has caused.

Our technical team identified this was caused by poor network connectivity and has restored service.
Posted Sep 10, 2024 - 01:14 UTC
Monitoring
We're aware some customers may be experiencing some slowness across Xero.
Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 12:49am UTC
Posted Sep 10, 2024 - 00:49 UTC
This incident affected: Xero Platform and Settings.