Our team has resolved the issue impacting Australian customers trying to log into Xero. We apologise for any inconvenience this has caused. This was caused by a third-party external service provider.
When there’s an issue with our third-party suppliers/external service providers, we work closely with them to understand the impact and push for a resolution as quickly as possible.
Posted Jan 23, 2025 - 22:39 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.
Status Last Reviewed: 10:14pm UTC
Posted Jan 23, 2025 - 22:14 UTC
Investigating
We are aware some Australian customers trying to log into Xero are experiencing a loading page. Our team is investigating this with urgency.
Status Last Reviewed: 9:42pm UTC
Posted Jan 23, 2025 - 21:42 UTC
This incident affected: Xero Platform and Settings.