Xero Central - customers unable to raise cases
Incident Report for Xero
Resolved
Our team has resolved the issue impacting customers from being able to raise cases in Xero Central. We apologise for any inconvenience this has caused.

A product release caused this feature to become unavailable. We've rolled back the release and services are back to normal.
Posted Sep 19, 2023 - 00:00 UTC
Investigating
We are aware customers are currently unable to raise cases on Xero Central. Our team is investigating this with urgency.

Status Last Reviewed: 11.50pm UTC
Posted Sep 18, 2023 - 23:50 UTC
This incident affected: Xero Central.