Our team has resolved the issue impacting some UK customers trying to submit via MTD IT. This was due to a recent release, which we have deployed a fix for.
Posted Sep 07, 2026 - 19:26 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.
Posted Sep 07, 2026 - 18:41 UTC
Identified
We have identified the cause of the issue where some UK customers trying to submit via MTD IT are receiving error messages. Our team are working on a fix for this issue.
Posted Sep 07, 2026 - 15:46 UTC
Investigating
We are aware some UK customers trying to submit filings via MTD IT are receiving error messages. Our team is investigating this with urgency.
Posted Sep 07, 2026 - 15:30 UTC
This incident affected: United Kingdom - Regional Products (Tax Reporting - UK VAT & MTD).