Some users experiencing performance issues in Xero
Incident Report for Xero
Resolved
This incident has been resolved.
Posted Jul 21, 2021 - 03:46 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 21, 2021 - 03:20 UTC
Investigating
We’re currently aware of performance issues in Xero. Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted Jul 21, 2021 - 02:04 UTC
This incident affected: Xero Platform and Settings.