Xero HQ Client List - not loading for customers
Incident Report for Xero
Resolved
Our team has resolved the issue impacting customers trying to access the Xero HQ client list. We apologise for any inconvenience this has caused.

Within 24 hours we’ll update this page with a brief summary
Posted Dec 14, 2022 - 02:47 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 1:53 AM UTC
Posted Dec 14, 2022 - 01:53 UTC
Investigating
We are aware customers trying to access the Xero HQ client list are unable to. Our team is investigating this with urgency.

Status Last Reviewed: 1:28 AM UTC
Posted Dec 14, 2022 - 01:28 UTC
This incident affected: Xero Partner Products & Tools (Xero HQ).