Global: New Invoicing - Approve buttons not loading for some customers
Incident Report for Xero
Resolved
Our team has resolved the issue that some customers experienced trying to approve invoices in New Invoicing.

We found this issue was due to a previous release which has been reverted. We apologise for the inconvenience caused.
Posted Apr 16, 2024 - 14:44 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 13:48 UTC.
Posted Apr 16, 2024 - 13:48 UTC
Investigating
We are aware that some customers trying to approve invoices in New Invoicing are experiencing issues with loading. Our team is investigating this with urgency.

Status Last Reviewed: 12:08 UTC.
Posted Apr 16, 2024 - 10:24 UTC
This incident affected: Core Xero Products (Invoicing, Bills & Quotes).