Global: Some customers are experiencing errors and slowness when accessing Xero

Incident Report for Xero

Resolved

Our team has resolved the issue causing some customers to experience errors and slowness across Xero. This was related to a product release which has been rolled back. We apologise for any inconvenience this has caused.
Posted Oct 27, 2025 - 11:09 UTC

Monitoring

Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 10:54
Posted Oct 27, 2025 - 10:54 UTC

Investigating

We are aware some customers are experiencing errors and slowness when accessing Xero. Our team is investigating this with urgency.

Status Last Reviewed: UTC 10:48
Posted Oct 27, 2025 - 10:48 UTC
This incident affected: Xero Platform and Settings.