Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 06, 2026 - 18:30 UTC
Scheduled
We’re carrying out scheduled system maintenance on Sunday 7 June 2026 between 6.30am to 7.45am NZT / 4:30am to 5.45am AEST (6:30pm to 7:45pm Saturday 6 June UTC) .
During this time, some customers may experience degraded performance within Xero. Maintenance will be completed by 7.45am NZT / 5.45am AEST (7.45pm Saturday 6 June UTC).
Thank you for your patience.
Posted Jun 05, 2026 - 02:45 UTC
This scheduled maintenance affected: Xero Platform and Settings.