Performance issues with WorkflowMax, Xero Practice Manager and Tax
Incident Report for Xero
Resolved
Our Product Team have resolved the performance issues with WorkflowMax, Xero Practice Manager and Tax

Please let us know if you still have any further issues.
Posted 3 months ago. Aug 07, 2018 - 14:43 NZST
Update
Our Product Team are doing everything they can to get you back going on WorkflowMax, Xero Practice Manager and Tax. Thanks for your patience.
Posted 3 months ago. Aug 07, 2018 - 14:27 NZST
Update
Just to let you know that we’re still working on this - we’ll update you as soon as we have more information.
Posted 3 months ago. Aug 07, 2018 - 14:10 NZST
Update
We’re currently aware of an issue with the performance of WorkflowMax, Xero Practice Manager and Tax. Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted 3 months ago. Aug 07, 2018 - 13:58 NZST
Investigating
We are currently investigating this issue.
Posted 3 months ago. Aug 07, 2018 - 13:56 NZST
This incident affected: Partner Tools & WorkflowMax (Practice Manager and WorkflowMax, Xero Tax (Australia)).