Some users are experiencing slowness in some areas of Xero
Incident Report for Xero
Resolved
Our Product Team have resolved the issue that was causing degraded performance mainly around contacts.

Please let us know if you still have any issues with this, and we’ll be happy to investigate further.
Posted 12 days ago. Nov 06, 2018 - 07:06 NZDT
Update
We are continuing to investigate this issue.
Posted 12 days ago. Nov 06, 2018 - 06:40 NZDT
Update
We’re still investigating this issue. Thanks again for your patience.
Posted 12 days ago. Nov 06, 2018 - 06:13 NZDT
Update
Fixing this issue is our top priority right now, as we can appreciate the impact this is having for our users. Thanks for your patience.
Posted 12 days ago. Nov 06, 2018 - 06:02 NZDT
Update
Our Product Team are still investigating this issue and we're looking to get things up and running soon. Apologies for any inconvenience caused by this.
Posted 12 days ago. Nov 06, 2018 - 05:50 NZDT
Update
We are continuing to investigate this issue.
Posted 12 days ago. Nov 06, 2018 - 05:34 NZDT
Investigating
We're currently aware of an Issue where some users are experiencing degraded performance mainly around contacts. Our Product Team are currently investigating.
Posted 12 days ago. Nov 06, 2018 - 05:29 NZDT
This incident affected: Xero.