Global: Xero Central - Some customers are Unable to Access Xero Central

Incident Report for Xero

Resolved

Our team has resolved the issue preventing customers from accessing Xero Central. We apologise for any inconvenience this has caused.

Within 24 hours we’ll update this page with a brief summary
Posted Feb 20, 2025 - 23:40 UTC

Monitoring

Xero Central has been restored and we are monitoring for further impact.

Status Last Reviewed: 10:55 pm UTC
Posted Feb 20, 2025 - 22:55 UTC

Investigating

We are aware that some customers are intermittently unable to access Xero Central. Our team is investigating this with urgency.

Status Last Reviewed: 10:49 pm UTC
Posted Feb 20, 2025 - 22:17 UTC
This incident affected: Xero Central.