Global: Xero - Some users are experiencing errors across Xero

Incident Report for Xero

Resolved

Our team has resolved the issue causing some customers to experience errors across Xero. The issue was related to our recent release which our team has rolled back. We apologise for any inconvenience this has caused.
Posted Apr 07, 2026 - 09:46 UTC

Investigating

We are aware some customers are experiencing errors across Xero. Our team is investigating this with urgency.
Posted Apr 07, 2026 - 09:17 UTC
This incident affected: Xero Platform and Settings.