Hubdoc - some customers receiving errors when accessing Hubdoc
Incident Report for Xero
Resolved
Our team has confirmed that this issue is now resolved and customers can now access Hubdoc. We apologise for any inconvenience this has caused.
Posted Oct 24, 2024 - 08:10 UTC
Investigating
We are aware some customers are experiencing error messages when accessing Xero. Our team is investigating this with urgency.

Status Last Reviewed: 7.35am UTC
Posted Oct 24, 2024 - 06:50 UTC
This incident affected: Hubdoc.