Performance issues in Xero Payroll
Incident Report for Xero
Resolved
Our Product Team have resolved the issue that was causing performance issues in Xero Payroll.

Please let us know if you still have any issues with this, and we’ll investigate further.
Posted 3 months ago. Jul 03, 2018 - 16:02 NZST
Update
Fixing this issue is our top priority right now, as we can appreciate the impact this is having for our users.
Posted 3 months ago. Jul 03, 2018 - 15:48 NZST
Update
Our Product Team are doing everything they can to restore performance in Xero Payroll. Thanks for your patience.
Posted 3 months ago. Jul 03, 2018 - 15:04 NZST
Update
Just to let you know that we’re still working on this - we’ll update you as soon as we have more information.
Posted 3 months ago. Jul 03, 2018 - 14:34 NZST
Update
We’re currently aware of an issue regarding performance in Xero Payroll. Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted 3 months ago. Jul 03, 2018 - 14:06 NZST
Investigating
We are currently investigating this issue.
Posted 3 months ago. Jul 03, 2018 - 14:03 NZST
This incident affected: Xero.