Australia: Xero Tax - slowness in loading tax returns
Incident Report for Xero
Resolved
Our team has resolved the issue impacting Australian customers trying to open tax returns in Xero Tax. We apologise for any inconvenience this has caused.

Our technical team identified this was caused by poor network connectivity and has restored service.
Posted Jul 17, 2024 - 02:51 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 2:30am UTC
Posted Jul 17, 2024 - 02:29 UTC
Identified
We have identified what impacting Australian customers trying to load tax returns in Xero Tax.

This is our top priority and we will update you as soon as we can.

Status Last Reviewed: 2:15am UTC
Posted Jul 17, 2024 - 01:59 UTC
Investigating
We are aware Australian customers trying to load returns in Xero Tax are experiencing slowness or an error page. Our team is investigating this with urgency.

Status Last Reviewed: 1:45am UTC
Posted Jul 17, 2024 - 01:46 UTC
This incident affected: Xero Partner Products & Tools (Xero Tax (AU)).