UK: Tax - Errors and slowness with MTD ITSA and VAT

Incident Report for Xero

Resolved

HMRC have resolved the issue causing UK customers are experiencing slowness and error pages when using MTD ITSA or UK VAT.
Posted Aug 28, 2026 - 11:43 UTC

Investigating

We are aware some UK customers are experiencing slowness and error pages when using MTD ITSA or UK VAT. This is due to an increased error rate at HMRC services. We are investigating the issue and in contact with HMRC.
Posted Aug 28, 2026 - 09:15 UTC
This incident affected: United Kingdom - Regional Products (Tax Reporting - UK VAT & MTD).