Global: Hubdoc - Performance and login
Incident Report for
Xero
Resolved
Our team has resolved the issue impacting customers using Hubdoc. We apologise for any inconvenience this has caused.
Posted
Jan
09
,
2023
-
13:26
UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.
Status Last Reviewed:
13:11 UTC
Posted
Jan
09
,
2023
-
13:11
UTC
Investigating
We are aware customers trying to login to Hubdoc are experiencing error messages or slow performance. Our team is investigating this with urgency.
Status Last Reviewed:
12:16 UST.
Posted
Jan
09
,
2023
-
12:16
UTC
This incident affected: Hubdoc.
×
Subscribe to Incident
Subscribe to updates for
Global: Hubdoc - Performance and login
via . You'll receive .