Global: Invoicing - some customers cannot access invoicing
Incident Report for Xero
Resolved
Our team has resolved the issue impacting some customers trying to access invoicing in Xero. We apologise for any inconvenience this has caused.

Our technical team identified this was caused by poor network connectivity and has restored service.
Posted Sep 30, 2024 - 22:34 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 9:46pm UTC
Posted Sep 30, 2024 - 21:31 UTC
Identified
We have identified what is preventing customers trying to access invoicing in Xero.

This is our top priority and we will update you as soon as we can.

Status Last Reviewed: 9:03pm UTC
Posted Sep 30, 2024 - 21:04 UTC
This incident affected: Core Xero Products (Invoicing, Bills & Quotes).