Some users are experiencing slowness or unresponsiveness when accessing Xero Practice Manager and Xero Tax
Incident Report for Xero
Resolved
This incident has been resolved.
Posted Sep 03, 2021 - 01:44 UTC
Update
We are continuing to monitor for any further issues.
Posted Sep 03, 2021 - 00:51 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 03, 2021 - 00:44 UTC
Investigating
We’re currently aware of an issue where some users are experiencing slowness or unresponsiveness when accessing Xero Practice Manager and Xero tax

Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted Sep 03, 2021 - 00:30 UTC
This incident affected: Xero Platform and Settings.