Customers experiencing slowness across Xero
Incident Report for Xero
Resolved
Our team has resolved the issue that caused customers to experience slowness across the Xero platform. This related to a network connectivity error that our system experienced which caused customers to experience slowness for a short period of time until our engineers were able to resolve this issue. We apologise for any inconvenience this has caused.
Posted May 02, 2023 - 00:43 UTC
Monitoring
Our team has implemented a fix and we are currently monitoring the results.

Status Last Reviewed: 12.14am UTC
Posted May 02, 2023 - 00:14 UTC
Investigating
We are aware customers are experiencing general slowness and error messages across Xero. Our team is investigating this with urgency.

Status Last Reviewed: 11.48pm UTC
Posted May 01, 2023 - 23:48 UTC
This incident affected: Xero Platform and Settings.