Global: Xero - Customers are experiencing issues in Xero
Incident Report for Xero
Resolved
Our team has resolved the issue impacting some customers trying to navigate in Xero. We apologise for any inconvenience this has caused.

Our technical team identified this was caused by poor network connectivity and has restored service.
Posted Oct 30, 2023 - 02:41 UTC
Monitoring
We are aware some customers trying to navigate in Xero are experiencing issues. Our team is investigating this with urgency.

A fix has been implemented however some customers have found that clearing their cookies and cache has resolved things for them.

Status Last Reviewed: 2:16am UTC
Posted Oct 30, 2023 - 02:16 UTC