Global: Products and Services - Unable to create new item
Incident Report for Xero
Resolved
Our team has resolved the issue impacting customers trying to create a new item in Products and Services. We apologise for any inconvenience this has caused.

Our technical team identified this was caused by poor network connectivity and has restored service.
Posted Sep 04, 2023 - 23:55 UTC
Investigating
We are aware customers trying to create a new item in Products and Services are experiencing issues. Our team is investigating this with urgency.

Status Last Reviewed: 10:53am UTC
Posted Sep 04, 2023 - 22:54 UTC
This incident affected: Core Xero Products (Products and services).