Global: WorkflowMax - Some customers unable to login
Incident Report for Xero
Resolved
Our team has resolved the issue causing some customers to be unable to login to WorkflowMax. This issue related to a network connectivity issue which our team implemented a fix for to resolve customer impact. We apologise for any inconvenience caused.
Posted Jun 14, 2024 - 21:23 UTC
Investigating
We are aware that some customers are currently unable to login to WorkflowMax. Our team is investigating this with urgency.

Status Last Reviewed: 20:55 UTC
Posted Jun 14, 2024 - 20:17 UTC
This incident affected: WorkflowMax.