Global: XPM - Customers may be experiencing delays with actions performed

Incident Report for Xero

Resolved

Our team has resolved the issue causing delays to some actions performed in XPM. We apologise for any inconvenience this has caused.

Our technical team identified this was caused by poor network connectivity and has restored service.
Posted Nov 09, 2023 - 00:06 UTC

Identified

We have identified what is causing delays with actions performed in XPM.

This is our top priority and we will update you as soon as we can.

Status Last Reviewed: 11:36pm UTC
Posted Nov 08, 2023 - 23:37 UTC
This incident affected: Xero Partner Products & Tools (Xero Practice Manager (XPM)).