Users are experiencing intermittent issues with Xero Signing
Incident Report for Xero
Resolved
Our Product Team have resolved the issue that was preventing users from signing documents through Xero Signing.

Please let us know if you still have any issues with this, and we’ll investigate further.
Posted Jan 19, 2021 - 00:10 UTC
Update
Just to let you know that we’re still working on this - we’ll update you as soon as we have more information.
Posted Jan 18, 2021 - 23:45 UTC
Investigating
We’re currently aware of intermittent issues or slow responses when attempting to send or sign documents through Xero Signing.

Our Product Team is investigating this with urgency.

Apologies for the inconvenience this is causing you - we’ll update you as soon as we have any news.
Posted Jan 18, 2021 - 22:59 UTC
This incident affected: Xero.