TPP The People's Pension - UK Superannuation provider
Incident Report for Xero
Resolved
This incident has been resolved.
Posted May 04, 2021 - 01:49 UTC
Update
The People's Pension (TPP) scheduled maintenance in the UK is currently in progress until 3pm Monday, 3 May 2021.
Posted May 02, 2021 - 07:58 UTC
Investigating
The People's Pension (TPP) Integration in the UK will be unavailable from 9am Sunday, 2 May - 3pm Monday, 3 May 2021 (BST). This is due to scheduled maintenance. If you experience any issues connecting or filing during this time, please try again after the maintenance period.
Posted Apr 30, 2021 - 07:38 UTC
This incident affected: Xero Platform and Settings.