Global: Xero Tax - Users cannot request e-signature
Incident Report for
Xero
Resolved
Our team has resolved the issue impacting customers trying to request e-signatures in Xero Tax. We apologise for any inconvenience this has caused.
A product release caused this feature to become unavailable. We've rolled back the release and services are back to normal.
Posted
Oct
24
,
2023
-
23:31
UTC
Investigating
We are aware customers trying to request e-signatures in Xero Tax in are experiencing issues. Our team is investigating this with urgency.
Status Last Reviewed:
11:02PM UTC
Posted
Oct
24
,
2023
-
23:04
UTC
This incident affected: Xero Partner Products & Tools (Xero Tax (NZ)).
×
Subscribe to Incident
Subscribe to updates for
Global: Xero Tax - Users cannot request e-signature
via . You'll receive .