Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 12, 2025 - 18:00 UTC
Scheduled
We will be undertaking planned system maintenance at 6pm UTC Saturday, 12 April. During this time, customers may experience a service disruption for a period of 30 seconds. Thanks for your patience during this time.
Posted Apr 08, 2025 - 01:35 UTC
This scheduled maintenance affected: Xero Platform and Settings.